[Ruby] Solution when gem’rails-i18n’,’~> 6.0.0’ is added and an error occurs in bundle install

1 minute read

The appearance of an error

To localize error messages in Rails 5 Add the following to Gemfile

gem'rails-i18n','~> 6.0.0'

Next, at the terminal

$ bundle install

When I execute, the following error occurs and the installation cannot be done.

``` execution result

The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for.Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java.To add those platforms to the bundle, run bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java. Fetching gem metadata from https://rubygems.org/………… Fetching gem metadata from https://rubygems.org/. Resolving dependencies… Bundler could not find compatible versions for gem “railties”: In snapshot (Gemfile.lock): railties (=

In Gemfile: coffee-rails (~> 4.2) was resolved to 4.2.2, which depends on railties (>= 4.0.0)

rails (~> 5.2.4, >= was resolved to, which depends on
  railties (=

rails-i18n (~> 6.0.0) was resolved to 6.0.0, which depends on
  railties (>= 6.0.0, <7)

sass-rails (~> 5.0) was resolved to 5.1.0, which depends on
  railties (>= 5.2.0)

web-console (>= 3.3.0) was resolved to 3.7.0, which depends on
  railties (>= 5.0)

Running bundle update will rebuild your snapshot from scratch, using only the gems in your Gemfile, which may resolve the conflict.

# Error cause

gem’rails-i18n’,’~> 6.0.0’

The version specification of was wrong.
The above version was for `rails6`.

# Solution
The version of `rails` this time was `rails5`, so in that case,

gem’rails-i18n’,’~> 5.1’

Then OK! !!


$ bundle install ``` I was able to install it safely.